Upgrade do Ubuntu 10.04 para 10.10: An unresolvable problem occurred while calculating the upgrade

Linux, Ubuntu No Comments

Essa semana atualizei o ubuntu que estava na minha máquina da versão 8.04 até a 10.10.

Para fazer esse upgrade tive que atualizar versão por versão, nada que fosse muito difícil já que o programa de atualização faz tudo automaticamente.

Ao tentar migrar da versão 10.04 para a versão 10.10 apareceu o seguinte erro:

Could not determine the upgrade
An unresolvable problem occurred while calculating the upgrade:
E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
This can be caused by:
  * Upgrading to a pre-release version of Ubuntu
  * Running the current pre-release version of Ubuntu
  * Unofficial software packages not provided by Ubuntu

Após algumas pesquisas na internet a solução foi remover o pacote xserver-xorg-video-nouveau através do comando:

apt-get --purge remove xserver-xorg-video-nouveau

Fontes:
http://ubuntuforums.org/showthread.php?t=1664249
https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/614993

Upgrade para o Ubuntu 9.10

Ubuntu No Comments

Hoje migrei o Ubuntu da versão 9.04 para 9.10.

Tive apenas um único problema que o Firefox ficou com fontes estranhas no menu. Para resolver este problema basta fazer o seguinte:

sudo rm /etc/fonts/conf.d/10-hinting-slight.conf
sudo ln -s /etc/fonts/conf.avail/10-hinting-full.conf /etc/fonts/conf.d/

A correção acima foi retirada de http://ubuntu-virginia.ubuntuforums.org/showthread.php?t=1305969.

Uma melhoria que fiz foi utilizar a nova versão do amsn, para isto basta adicionar o seguinte repositório no ubuntu (http://www.ubuntu-inside.me/2009/05/amsn-daily-repository-for-ubuntu-jaunty.html):

deb http://ppa.launchpad.net/amsn-daily/ppa/ubuntu karmic main

De resto, foi tudo tranquilo.

Ubuntu + Kodak C743

Linux, Ubuntu No Comments

Para utilizar a câmera digital Kodak EasyShare C743, basta criar o arquivo “/etc/udev/rules.d/KodakC743.rules” com o seguinte conteúdo:

ACTION=="add", SYSFS{idVendor}=="Eastman Kodak Company", SYSFS{idProduct}=="KODAK EasyShare C743 Zoom Digital Camera", MODE="0660", GROUP="plugdev"

E rodar o seguinte comando: “sudo /etc/init.d/udev restart”

Para saber qual é o idVendor e o idProduct basta executar: “for dev in `ls /sys/bus/usb/devices`; do udevinfo -ap /sys/bus/usb/devices/$dev; done”

Retirado de:
http://linuxnet.blogspot.com/2007/03/kodak-c743-no-ubuntu-610.html
http://ubuntuforums.org/showthread.php?t=286730

Ubuntu + Nokia 6235

Ubuntu No Comments

Para conectar o nokia 6235 no ubuntu, basta instalar o pacote obexfs e colocar no arquivo “/etc/fstab” a seguinte linha “obexfs#-u0      /media/fuse     fuse    user,fsname=obexfs#-u0  0       0″.

Após conectar o celular basta digitar no console:

“sudo mount -a”

Redirado de: http://dev.zuckschwerdt.org/openobex/wiki/ObexFs

Ubuntu + Alsa + Flash = Device or resource busy

Ubuntu No Comments

Após atualizar o ubuntu para 8.04 no trabalho, não estava mais com sons simultâneos com o flash e o alsa.

Quando tentava fazer: “aplay /usr/share/sounds/startup.wav” recebia o seguinte erro:

ALSA lib pcm_dmix.c:874:(snd_pcm_dmix_open) unable to open slave
aplay: main:546: audio open error: Device or resource busy

Para arrumar isto basta criar o arquivo “/etc/asound.conf”, com o seguinte conteúdo:

pcm.!default {
    type pulse
}
ctl.!default {
    type pulse
}

E adicionar o seguinte pacote no ubuntu: libasound2-plugins.

Upgrade Ubuntu e problema no Postgre

Linux, Postgre, Ubuntu No Comments

Após atualizar o Ubuntu para a versão 8.04, o servidor do postgre não iniciava mais com o seguinte erro:

 * The PostgreSQL server failed to start. Please check the log output:
BRT LOG:  could not load root certificate file "root.crt": no SSL error reported
BRT DETAIL:  Will not verify client certificates.
BRT FATAL:  could not create shared memory segment: Invalid argument
BRT DETAIL:  Failed system call was shmget(key=5432001, size=34504704, 03600).
BRT HINT:  This error usually means that PostgreSQL's request for a shared memory
segment exceeded your kernel's SHMMAX parameter.  You can either reduce the
request size or reconfigure the kernel with larger SHMMAX.  To reduce the request
size (currently 34504704 bytes), reduce PostgreSQL's shared_buffers parameter
(currently 3456) and/or its max_connections parameter (currently 103).
	If the request size is already small, it's possible that it is less than your
kernel's SHMMIN parameter, in which case raising the request size or reconfiguring
SHMMIN is called for.
	The PostgreSQL documentation contains more information about shared
memory configuration.

Foi necessário alterar o arquivo “/etc/postgresql/8.3/main/postgresql.conf”, trocando o valor da variável “shared_buffers” de “32MB” para “26MB”.

Ubuntu e Locale

Linux, Ubuntu No Comments

Para se alterar o locale padrão do sistema, basta seguir esses passos:

  • Adicione o seguinte texto “en_US.ISO-8859-1 ISO-8859-1″ no final do arquivo “/var/lib/locales/supported.d/local”
  • Troque o valor da variável “LANG” no arquivo “/etc/default/locale” por “en_US.ISO-8859-1″
  • Execute o commando “sudo locale-gen –purge”

Após estes passos, basta reiniciar o sistema!

Upgrade Ubuntu 7.10 para 8.04

Linux, Ubuntu No Comments

Hoje no trabalho fiz o upgrade do Ubuntu 7.10 para 8.04. Foram quase 900MB para serem baixados, e o upgrade durou cerca de 40 minutos!!!

Por enquanto não tive nenhum problema após a migração, mas talvez seja porque hoje é sexta-feira e saí mais cedo do serviço. Vamos ver na segunda-feira se tudo está ok!!!

Problemas no upgrade do Kubuntu 7.10 para 8.04

Linux, Ubuntu No Comments

Após o upgrade de versão do Kubuntu 7.10 para o 8.04 tive alguns pequenos problemas:

  • Apache2 + SVN: reclamando que faltava o MPM (só foi instalar o pacote apache2-mpm-worker)
  • Splash Screen do KDE: ocorria um erro ao carregar (só foi instalar o pacote ksplash-engine-moodin)

E o problema mais chato que tive foi que o som não estava mais funcionando. Após pesquisar muito achei alguns bugs abertos sobre este problema. Uma das soluções encontradas foi instalar o alsa à partir do código fonte:

sudo apt-get install module-assistant
sudo m-a update
sudo m-a prepare
sudo m-a a-i alsa
sudo modprobe snd-hda-intel
sudo /etc/init.d/alsa-utils reset

Após isto o som já estará funcionando. Bom, por enquanto foram apenas estes problemas encontrados!

Debug no Tomcat 5.5

Java EE, Programação 1 Comment

Para rodar um debug remoto no tomcat 5.5 no Ubuntu, basta editar o arquivo “/etc/init.d/tomcat5.5″ e colocar a seguinte linha:


-Xdebug -Xrunjdwp:transport=dt_socket,address=8000,server=y,suspend=n

antes das linhas:


# Define other required variables
CATALINA_PID="/var/run/$NAME.pid"
BOOTSTRAP_CLASS=org.apache.catalina.startup.Bootstrap
JSVC_CLASSPATH="/usr/share/java/commons-daemon.jar:$CATALINA_HOME/bin/bootstrap.jar"

« Previous Entries